Instalar módulo de segurança dos Bancos no Ubuntu 18.04 – WARSAW

warsaw-e-gbplugin

NOTA SOBRE O TUTORIAL
Todos os procedimento aqui realizados foram feitos em um notebook e depois em uma máquina virtual com o Ubuntu 18.04, no Firefox 60 e no Google Chrome 66.
Após muita pesquisa e lendo que muita gente está com o mesmo problema (apesar de que não uso, foi para um cliente) encontrei uma alma caridosa em um comentário que descobriu onde está o problema.

1º PASSO – Realize a instalação das dependências antes de instalar o aplicativo.

sudo apt install libnss3-tools libcurl3

2º PASSO – Baixe o “warsaw” mais atualizado, pode escolher qualquer um, porque o pacote é mesmo.

http://www.dieboldnixdorf.com.br/warsaw
ou baixe diretamente pelo terminal
wget https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw-setup-ubuntu_64.deb

AGORA O PULO DO GATO!! O problema na instalação é que ele tem dependência com o pacote python-gpgme que foi renomeado para python-gpg nas novas versões do Ubuntu. Portanto é preciso editar as dependências do pacote e alterar o script python deste para usar o import do gpg ao invés do gpgme.

3º PASSO – Abra o terminal no diretório onde salvou o pacote e execute o comando abaixo:

dpkg-deb -R warsaw-setup-ubuntu_64.deb warsaw

4º PASSO – Abra o arquivo “control” com o comando abaixo, e depois troque python-gpgme por python-gpg e libcurl3 por libcurl4 e depois salve.

gedit warsaw/DEBIAN/control

5º PASSO – Abra o arquivo o arquivo “warsaw” com o comando abaixo, e depois troque TODOS gpgme por gpg e salve.
LEMBRANDO que é para trocar apenas a palavra “gpgme”. Ex: A linha gpgme_context ficará “gpg_context”

gedit warsaw/usr/bin/warsaw

6º PASSO – Agora vamos fechar o pacote e renomeá-lo.

dpkg-deb -b warsaw warsaw_corrigido.deb

7º PASSO – Execute o comando de instalação abaixo junto com o comando de correção.

sudo dpkg -i warsaw_corrigido.deb ; sudo apt install -f

PRONTO!
Agora abra a página do Banco e teste. Aqui não precisei de reiniciar, como pedem por aí.
Você pode abrir os sites abaixo e testar para ter a certeza que tá tudo bem.
http://www.dieboldnixdorf.com.br/warsaw https://internetbanking.caixa.gov.br/sinbc/nb/login/redirecionaDispSeguranca https://www2.bancobrasil.com.br/aapf/login.jsp
P.S.: Se mesmo assim, o banco ainda pedir o módulo, execute novamente os procedimentos conforme solicitado pelo site do banco.

Após testes consegui usar normalmente com o Banco do Brasil. Como se trata do mesmo aplicativo de segurança, para todos os Bancos no Brasil, provavelmente funcionará nos demais.

Agnel Póvoa
Palmas, Tocantins-BR
agnelpovoa at gmail.com

Fontes:
http://www.edivaldobrito.com.br/modulo-de-seguranca-do-banco-do-brasil-no-linux/ http://www.edivaldobrito.com.br/modulo-de-seguranca-do-banco-do-brasil-no-linux/#comment-3881814391
https://ubuntuforum-br.org/index.php?topic=122920.0
https://ubuntuforum-br.org/index.php?PHPSESSID=1jsmmqrm94kqjqd7hg5ibo8qm6&topic=121558.msg674941#msg674941
https://ubuntuforum-br.org/index.php?topic=121558.msg668266#msg668266

 

 

 

 

Anúncios

12 comentários sobre “Instalar módulo de segurança dos Bancos no Ubuntu 18.04 – WARSAW

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.